[webkit-reviews] review granted: [Bug 44433] Add AsyncFileSystem interface for platform-dependent FileSystem API implementation : [Attachment 65524] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Thu Aug 26 23:25:32 PDT 2010


Darin Fisher (:fishd, Google) <fishd at chromium.org> has granted Kinuko Yasuda
<kinuko at chromium.org>'s request for review:
Bug 44433: Add AsyncFileSystem interface for platform-dependent FileSystem API
implementation
https://bugs.webkit.org/show_bug.cgi?id=44433

Attachment 65524: Patch
https://bugs.webkit.org/attachment.cgi?id=65524&action=review

------- Additional Comments from Darin Fisher (:fishd, Google)
<fishd at chromium.org>
WebCore/platform/AsyncFileSystem.h:62
 +	static void openFileSystem(const String& basePath, const String&
storageIdentifier, Type, PassOwnPtr<AsyncFileSystemCallbacks>);
I don't understand the comment about passing ownership of 'this' since this
method is static.  There is no 'this' pointer.

WebCore/platform/AsyncFileSystemCallbacks.h:57
 +	virtual void didReadDirectoryChunkDone(bool hasMore) = 0;
The name of this method is a bit awkward sounding.  Perhaps
didReadDirectoryEntries would be a better name?  Pluralizing Entry suggests a
"chunk of entries", which seems similar to what you were trying to get at with
using Chunk in the name.  Also, the Done bit may be redundant with the hasMore
parameter, so leaving it as didReadDirectoryEntries seems reasonable to me.  It
just informs the callbacks that entries were read and more may be read soon. 
Works for me!


R=me w/ these two changes.


More information about the webkit-reviews mailing list