[webkit-reviews] review granted: [Bug 43589] Compositing should be exposed in terms of GraphicsContext3D, not WebGL specifically : [Attachment 63686] compile tested on mac with and without 3D_CANVAS enabled

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Fri Aug 6 08:53:09 PDT 2010


Simon Fraser (smfr) <simon.fraser at apple.com> has granted James Robinson
<jamesr at chromium.org>'s request for review:
Bug 43589: Compositing should be exposed in terms of GraphicsContext3D, not
WebGL specifically
https://bugs.webkit.org/show_bug.cgi?id=43589

Attachment 63686: compile tested on mac with and without 3D_CANVAS enabled
https://bugs.webkit.org/attachment.cgi?id=63686&action=review

------- Additional Comments from Simon Fraser (smfr) <simon.fraser at apple.com>
> diff --git a/WebCore/platform/graphics/GraphicsLayer.h
b/WebCore/platform/graphics/GraphicsLayer.h

> -#if ENABLE(3D_CANVAS)
> -    virtual void setContentsToWebGL(PlatformLayer*) { }
> -#endif
> +    virtual void setContentsToGraphicsContext3D(PlatformLayer*) { }

I think this name is a bit wordy, and not quite accurate: you're not passing a
GraphicsContext3D in. I think "setContentsTo3D() would be OK, or perhaps
setContentsTo3DLayer().

Even then, if this is used for an accelerated canvas, it's not just 3D. So
setContentsToCanvas()? setContentsToAcceleratedCanvas()?

r=me with a better name.


More information about the webkit-reviews mailing list