[webkit-reviews] review denied: [Bug 43276] Implements IDBKeyPath extractor. : [Attachment 63638] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Fri Aug 6 08:25:06 PDT 2010


Jeremy Orlow <jorlow at chromium.org> has denied  review:
Bug 43276: Implements IDBKeyPath extractor.
https://bugs.webkit.org/show_bug.cgi?id=43276

Attachment 63638: Patch
https://bugs.webkit.org/attachment.cgi?id=63638&action=review

------- Additional Comments from Jeremy Orlow <jorlow at chromium.org>
WebKit/chromium/src/WebIDBKeyPath.cpp:34
 +  #include "Vector.h"
<wtf/Vector.h>

WebKit/chromium/src/WebIDBKeyPath.cpp:36
 +  using WebCore::IDBKeyPathElement;
Just using WebCore;

WebKit/chromium/src/WebIDBKeyPath.cpp:51
 +	delete m_private;
maybe check to see if m_private is !0...and then set it to 0?

WebKit/chromium/public/WebIDBKeyPath.h:53
 +	void assign(WTF::Vector<WebCore::IDBKeyPathElement, 0>&);
typically we just make these all implicit conversions.	Is that not possible?

WebKit/chromium/public/WebIDBKeyPath.h:58
 +	WTF::Vector<WebCore::IDBKeyPathElement, 0>* m_private;
I just asked hans to make a PrivateOwnPtr class (like PrivatePrt..maybe
renaming it to PrivateRefPtr) for something similar.  Coordinate between
yourselves?

WebKit/chromium/public/WebIDBKeyPath.h:32
 +  namespace WebCore {
#if WEBKIT_IMPLEMENTATION

WebKit/chromium/public/WebIDBKeyPath.h:61
 +  void WebIDBParseKeyPath(const WebString&, WebIDBKeyPath*, int* error);
Do we have other base methods like this?  Maybe it should be a static method of
some class?


More information about the webkit-reviews mailing list