[webkit-reviews] review granted: [Bug 43526] JSArray storage of m_vector is suboptimal : [Attachment 63521] Path to change from using m_vector to m_storage

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Aug 4 21:46:12 PDT 2010


Geoffrey Garen <ggaren at apple.com> has granted Michael Saboff
<msaboff at apple.com>'s request for review:
Bug 43526: JSArray storage of m_vector is suboptimal
https://bugs.webkit.org/show_bug.cgi?id=43526

Attachment 63521: Path to change from using m_vector to m_storage
https://bugs.webkit.org/attachment.cgi?id=63521&action=review

------- Additional Comments from Geoffrey Garen <ggaren at apple.com>
JavaScriptCore/runtime/JSArray.cpp:851
 +  }
I couldn't figure out why you needed to add this initialization -- it doesn't
seem related to just changing what the Array points to. Am I missing something?


JavaScriptCore/runtime/JSArray.h:163
 +	    ArrayStorage *m_storage; // Copy of ArrayStorage.m_vector.	Used
for quick vector access and to materialize ArrayStorage ptr.
WebKit style guidelines specify "ArrayStorage*" rather than "ArrayStorage *".

I think the comment here is out of date now.

r=me on the meat of the change


More information about the webkit-reviews mailing list