[webkit-reviews] review denied: [Bug 43453] [chromium] The chromium API needs a WebMouseEvent class : [Attachment 63402] Fixed style issues

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Aug 4 01:04:16 PDT 2010


Darin Fisher (:fishd, Google) <fishd at chromium.org> has denied Jay Civelli
<jcivelli at chromium.org>'s request for review:
Bug 43453: [chromium] The chromium API needs a WebMouseEvent class
https://bugs.webkit.org/show_bug.cgi?id=43453

Attachment 63402: Fixed style issues
https://bugs.webkit.org/attachment.cgi?id=63402&action=review

------- Additional Comments from Darin Fisher (:fishd, Google)
<fishd at chromium.org>
Yeah, WebMouseEvent2 is obviously not going to cut it.	We probably should
rename the subclasses of WebInputEvent.  That way we don't have to change
our convention of using WebFoo for DOM thingies named Foo.  MouseEvent
should map to WebMouseEvent given that convention.

Maybe inner classes?  WebInputEvent::{Generic,Mouse,Wheel,Keyboard}?  The
downside to such a solution is that it forces the inclusion of WebInputEvent.h
in places that could previously just forward declare it.  We could also
try to do something using a union:

  struct WebInputEvent {
    enum {...} type;
    ... other common fields ...
    union {
      struct {
	...
      } mouse;
      struct {
	...
      } wheel;
      struct {
	...
      } keyboard;
    } data;
  };

Then it would still be valid to forward declare 'struct WebInputEvent'.

I need to think about this more, but those are some ideas...


More information about the webkit-reviews mailing list