[webkit-reviews] review denied: [Bug 34686] [Haiku] Improve MIME type data base implementation on Haiku : [Attachment 53112] [Haiku] Fall back to the system MIME database, return correct string for unknown types.

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Mon Apr 12 23:27:53 PDT 2010


David Levin <levin at chromium.org> has denied Stephan Aßmus
<superstippi at gmx.de>'s request for review:
Bug 34686: [Haiku] Improve MIME type data base implementation on Haiku
https://bugs.webkit.org/show_bug.cgi?id=34686

Attachment 53112: [Haiku] Fall back to the system MIME database, return correct
string for unknown types.
https://bugs.webkit.org/attachment.cgi?id=53112&action=review

------- Additional Comments from David Levin <levin at chromium.org>
r- for struct name change (and the fact that I can't get you to change it on
landing).


>  2010-04-10  Adam Barth  <abarth at webkit.org>
>  
>	   Unreviewed.	Rename m_forceSandboxFlags to m_forcedSandoxFlags, as
> Index: WebCore/platform/haiku/MIMETypeRegistryHaiku.cpp

> -static const ExtensionMap extensionMap [] = {
> +static const ExtensionMap sExtensionMap[] = {

Please don't change the name of this struct. WebKit doesn't use this style of
notation for static const arrays.


> +    // Try system mime database
Please add a "."

> +    String fakeFileName("filename.");
> +    fakeFileName.append(str);
> +
> +    BMimeType type;
> +    if (BMimeType::GuessMimeType(fakeFileName.utf8().data(), &type) == B_OK)


Mild concern about passing untrusted data (derived from ext) to system api, but
since it is a a null terminated string, this appears fine.


More information about the webkit-reviews mailing list