[webkit-reviews] review denied: [Bug 37220] Adding static method zeroPoint to class IntPoint. : [Attachment 52757] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Apr 7 12:41:47 PDT 2010


Darin Adler <darin at apple.com> has denied Luiz Agostini
<luiz.agostini at openbossa.org>'s request for review:
Bug 37220: Adding static method zeroPoint to class IntPoint.
https://bugs.webkit.org/show_bug.cgi?id=37220

Attachment 52757: Patch
https://bugs.webkit.org/attachment.cgi?id=52757&action=review

------- Additional Comments from Darin Adler <darin at apple.com>
If it's a class member, then it's IntPoint::zeroPoint(), which is worse than
IntPoint(). I think we either need it to be:

    inline IntPoint zeroIntPoint() { return IntPoint(); }

Or:

    static IntPoint zero() { return IntPoint(); }

So we don't repeat the word point twice.

I also think we should do this for FloatPoint too.


More information about the webkit-reviews mailing list