[webkit-reviews] review denied: [Bug 28806] [Qt] Make the WebInspector available as a widget class. : [Attachment 39254] Changes v0.4

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Sep 9 05:23:47 PDT 2009


Simon Hausmann <hausmann at webkit.org> has denied Jocelyn Turcotte
<jocelyn.turcotte at nokia.com>'s request for review:
Bug 28806: [Qt] Make the WebInspector available as a widget class.
https://bugs.webkit.org/show_bug.cgi?id=28806

Attachment 39254: Changes v0.4
https://bugs.webkit.org/attachment.cgi?id=39254&action=review

------- Additional Comments from Simon Hausmann <hausmann at webkit.org>
Comments from the API discussion in the office here:

> +    void dock();
> +    void undock();
> +    bool isDocked() const;
[...]
> +    void dockRequested();
> +    void undockRequested();

These functions/signals should disappear from the
public API, as the names don't feel right and we'd like
find a better solution in the future. For now it seems
safer to not expose this aspect of the UI.

> +    QWebInspector* inspector() const;

This function should not be part of the public API, too. It doesn't
add any real convenience, as the developer always has a pointer to the
inspector anyway, as owner.

> +    void inspectElementTriggered();

This signal should be renamed to

    void QWebPage::webInspectorTriggered(const QWebElement&);


More information about the webkit-reviews mailing list