[webkit-reviews] review canceled: [Bug 27651] [Qt] QWebPluginDatabase API : [Attachment 34896] Add arePathsEqual() function to the FileSystem files.

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Sun Sep 6 01:51:10 PDT 2009


Jakub Wieczorek <faw217 at gmail.com> has canceled Jakub Wieczorek
<faw217 at gmail.com>'s request for review:
Bug 27651: [Qt] QWebPluginDatabase API
https://bugs.webkit.org/show_bug.cgi?id=27651

Attachment 34896: Add arePathsEqual() function to the FileSystem files.
https://bugs.webkit.org/attachment.cgi?id=34896&action=review

------- Additional Comments from Jakub Wieczorek <faw217 at gmail.com>
(In reply to comment #45)
> (In reply to comment #33)
> > (From update of attachment 33894 [details] [details])
> > This seems OK.  Maybe it should be called normalizePathForComparison if
it's
> > only for comparison.  It's unclear what "normalize" should actually do? 
Does
> > it resolve symlinks?  Does it remove traililing '/' chars?	Does it return
the
> > ~1 windows form of paths?  r- for more explanation and or a better name...
> > 
> > In general I'm in favor of the concept though.  Another way would be to to
just
> > have a arePathsEqual function. :)
> 
> I admit I prefer a function that does one thing, normalize a path by for
> example removing redundant pieces. arePathsEqual does two things, normalize
and
> then compare. Unless the other operating systems have one function for both I

> can imagine that all the FileSystemXXX.cpp implementations are going to add
an
> internal function to normalize and then do a string comparision :)

Alright, I got back to the old patch and renamed the function to
normalizePathForComparison(), according to Eric's suggestion.
For Qt it uses QDir::cleanPath(). If other ports could use something similar,
it should be sufficient.
http://doc.trolltech.com/4.5/qdir.html#cleanPath


More information about the webkit-reviews mailing list