[webkit-reviews] review denied: [Bug 28095] [WINCE] W3C Geolocation backend : [Attachment 34370] W3C Geolocation for WINCE

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Tue Sep 1 18:05:55 PDT 2009


Adam Barth <abarth at webkit.org> has denied Kwang Yul Seo
<kwangyul.seo at gmail.com>'s request for review:
Bug 28095: [WINCE] W3C Geolocation backend
https://bugs.webkit.org/show_bug.cgi?id=28095

Attachment 34370: W3C Geolocation for WINCE
https://bugs.webkit.org/attachment.cgi?id=34370&action=review

------- Additional Comments from Adam Barth <abarth at webkit.org>
+ WAIT_OBJECT_0 + 1

This is super ugly.  Can we use enums to remove these magical constants?

+ m_selfRef = 0;

RefPtr is not designed to be use across threads like this.  I'm also not sure
if GeolocationServiceThread::~GeolocationServiceThread can close those handles
on a random thread.

+ domTimeStamp -= 0x19db1ded53e8000
+ domTimeStamp /= 10000000

Magic constants are the devil.

+ WNDCLASS wcex       = {0};

This and the following lines are not proper style.

+ GeolocationServiceWince.h

One class per file, please.


More information about the webkit-reviews mailing list