[webkit-reviews] review granted: [Bug 29987] Refactor RenderThemeChromiumMac and RenderThemeChromiumSkia to render media controls using GraphicsContext. : [Attachment 40752] Round 2 + ChangeLog

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Oct 7 08:18:47 PDT 2009


Eric Carlson <eric.carlson at apple.com> has granted Andrew Scherkus
<scherkus at chromium.org>'s request for review:
Bug 29987: Refactor RenderThemeChromiumMac and RenderThemeChromiumSkia to
render media controls using GraphicsContext.
https://bugs.webkit.org/show_bug.cgi?id=29987

Attachment 40752: Round 2 + ChangeLog
https://bugs.webkit.org/attachment.cgi?id=40752&action=review

------- Additional Comments from Eric Carlson <eric.carlson at apple.com>

> +HTMLMediaElement* parentMediaElement(RenderObject* o)
> +{
> +    Node* node = o->node();
> +    Node* mediaNode = node ? node->shadowAncestorNode() : 0;
> +    if (!mediaNode || (!mediaNode->hasTagName(HTMLNames::videoTag) &&
!mediaNode->hasTagName(HTMLNames::audioTag)))
> +	   return 0;
> +
> +    return static_cast<HTMLMediaElement*>(mediaNode);

I suggest naming this "toParentMediaElement" to match the pattern used
elsewhere in WebCore (toInputElement, toRenderXXXX, etc). This file seems like
the right place for the function.


> +class RenderMediaControlsChromium {
> +public:
> +    static bool shouldRenderMediaControlPart(ControlPart part, Element* e);

Don't need the parameter names here.

r=me with these minor changes.


More information about the webkit-reviews mailing list