[webkit-reviews] review granted: [Bug 29069] [HTML5][Forms] min/max attributes support for type=number : [Attachment 40601] Proposed patch (rev.4)

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Sun Oct 4 19:27:13 PDT 2009


Darin Adler <darin at apple.com> has granted TAMURA, Kent <tkent at chromium.org>'s
request for review:
Bug 29069: [HTML5][Forms] min/max attributes support for type=number
https://bugs.webkit.org/show_bug.cgi?id=29069

Attachment 40601: Proposed patch (rev.4)
https://bugs.webkit.org/attachment.cgi?id=40601&action=review

------- Additional Comments from Darin Adler <darin at apple.com>
> +    // Returns the minimum value for type=range.  Don't call this for other
types.
> +    double minRange() const;

I think this should be named rangeMinimum(), not minRange(), which sounds like
"minimum range" to me.

> +    // Returns the maximum value for type=range.  Don't call this for other
types.
> +    // This always returns a value which is <= minRange().
> +    double maxRange() const;

And rangeMaximum() for this.

Otherwise seems fine to me, r=me


More information about the webkit-reviews mailing list