[webkit-reviews] review granted: [Bug 31569] Initial implementation of WebKitSharedScript and SharedScriptContext : [Attachment 43809] Updated per David's comments.

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Tue Nov 24 14:55:47 PST 2009


David Levin <levin at chromium.org> has granted Dmitry Titov
<dimich at chromium.org>'s request for review:
Bug 31569: Initial implementation of WebKitSharedScript and SharedScriptContext
https://bugs.webkit.org/show_bug.cgi?id=31569

Attachment 43809: Updated per David's comments.
https://bugs.webkit.org/attachment.cgi?id=43809&action=review

------- Additional Comments from David Levin <levin at chromium.org>

> diff --git a/WebCore/sharedScript/SharedScriptContext.cpp
b/WebCore/sharedScript/SharedScriptContext.cpp

> +void SharedScriptContext::addToDocumentsList(Document* context)

Would be nice to call it document instead of context.

> +void SharedScriptContext::removeFromDocumentList(Document* context)

Ditto.

> +void SharedScriptContext::removeFromDocumentList(Document* context)

Ditto.

It would be nice to not set-up the timer if it isn't needed.

> +    m_destructionTimer.startOneShot(destructionInterval);


More information about the webkit-reviews mailing list