[webkit-reviews] review granted: [Bug 30291] When effectAllowed = "uninitialized", incorrect dropEffect returned : [Attachment 42885] Patch
bugzilla-daemon at webkit.org
bugzilla-daemon at webkit.org
Tue Nov 10 15:10:40 PST 2009
Darin Adler <darin at apple.com> has granted Daniel Bates <dbates at webkit.org>'s
request for review:
Bug 30291: When effectAllowed = "uninitialized", incorrect dropEffect returned
https://bugs.webkit.org/show_bug.cgi?id=30291
Attachment 42885: Patch
https://bugs.webkit.org/attachment.cgi?id=42885&action=review
------- Additional Comments from Darin Adler <darin at apple.com>
r=me
But this test could be improved with one tiny change.
This line:
shouldEvaluateTo('event.dataTransfer.dropEffect',
'dropEffectElem.options[dropEffectElem.selectedIndex].value');
Should be changed to:
shouldBe('event.dataTransfer.dropEffect',
dropEffectElem.options[dropEffectElem.selectedIndex].value);
This would then make the test output easy to read because you could see the
actual result strings instead of the expression over and over again.
I'm really surprised by the shouldEvaluateTo function. I don't know who added
it and when, and I think I should look into this a bit more. When the second
argument is a string, it's the same as shouldBe, so I'm kind of mystified why
we would need it in that case.
More information about the webkit-reviews
mailing list