[webkit-reviews] review granted: [Bug 25613] [GTK] Allow to embed any GtkWidget for embed/object : [Attachment 30096] Implement Widget::setIsSelected by setting a property (when it exists)
bugzilla-daemon at webkit.org
bugzilla-daemon at webkit.org
Tue May 26 14:14:46 PDT 2009
Gustavo Noronha (kov) <gns at gnome.org> has granted Holger Freyther
<zecke at selfish.org>'s request for review:
Bug 25613: [GTK] Allow to embed any GtkWidget for embed/object
https://bugs.webkit.org/show_bug.cgi?id=25613
Attachment 30096: Implement Widget::setIsSelected by setting a property (when
it exists)
https://bugs.webkit.org/attachment.cgi?id=30096&action=review
------- Additional Comments from Gustavo Noronha (kov) <gns at gnome.org>
> + Implement Widget::setIsSelected for Gtk+ by searching
> + for a signal of the name widget-set-is-selected and if
> + this signal is available in the instance we have then
> + emit it. The signal signature does expect one gboolean
> + parameter and to return nothing.
^^
property.
> + g_object_set(platformWidget(), "widget-set-is-selected", isSelected,
NULL);
I'd name it 'webkit-widget-is-selected'. I think we want to make the library be
the namespace here, because the widget is selected in the context of our
library; 'set' is something we would expect to see in a method name, not in a
property IMO. With this change, r=me. I'm tagging r+ since Xan already reviewed
and suggested adding webkit-, as well. I don't think he'll opppose to s/set-//.
More information about the webkit-reviews
mailing list