[webkit-reviews] review requested: [Bug 25709] Skia/Cairo image decoders should be merged : [Attachment 30210] Part one - v1

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Mon May 11 17:39:54 PDT 2009

Peter Kasting <pkasting at google.com> has asked  for review:
Bug 25709: Skia/Cairo image decoders should be merged

Attachment 30210: Part one - v1

------- Additional Comments from Peter Kasting <pkasting at google.com>
This does lots of easy changes to get the two sets of files much closer
together, mostly style fixes to the older Cairo code:
* Proper #include guard names
* Namespace names on the closing brackets
* Indent namespace contents in header files
* Class open brackets on same line
* Correct initializer list indenting
* NULL -> 0

Also a few other changes for better consistency:
* m_size -> size(), which is what the Skia code uses, and is slightly safer in
the case of subclasses
* Add/move a couple trivial lines

After this patch, most diffs between the two code should be actual functional

More information about the webkit-reviews mailing list