[webkit-reviews] review granted: [Bug 26425] Small Refactoring to Consolidate Common GDI Calls : [Attachment 31465] Part 1: BitmapInfo Refactoring

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Jun 17 16:45:30 PDT 2009


Adam Roben (aroben) <aroben at apple.com> has granted Brent Fulgham
<bfulgham at webkit.org>'s request for review:
Bug 26425: Small Refactoring to Consolidate Common GDI Calls
https://bugs.webkit.org/show_bug.cgi?id=26425

Attachment 31465: Part 1: BitmapInfo Refactoring
https://bugs.webkit.org/attachment.cgi?id=31465&action=review

------- Additional Comments from Adam Roben (aroben) <aroben at apple.com>
> +++ WebCore/ChangeLog (working copy)
> @@ -1,3 +1,31 @@
> +2009-06-17  Brent Fulgham  <bfulgham at webkit.org>
> +
> +	   Reviewed by NOBODY (OOPS!).
> +
> +	   Refactor a few common routines in the various Windows ports
> +	   and reduce some duplicated code.
> +
> +	   Refactor use of BITMAPINFO for the new BitmapInfo structure.

You should mention the Bugzilla URL in your ChangeLog.

> +	   BITMAPINFO bitmapInfo = BitmapInfo::create(dstRect.size());

Might as well use BitmapInfo here, too.

You could give BitmapInfo a constructor that initialized bmiHeader.biSize
correctly and everything else to 0. That would follow the way ATL's C++
wrappers work. Or you could leave it like you have it now.

r=me


More information about the webkit-reviews mailing list