[webkit-reviews] review granted: [Bug 27627] DRT animation/transition pause API does not pause accelerated animations : [Attachment 33385] Patch, changelogs

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Fri Jul 24 11:33:45 PDT 2009


mitz at webkit.org has granted Simon Fraser (smfr) <simon.fraser at apple.com>'s
request for review:
Bug 27627: DRT animation/transition pause API does not pause accelerated
animations
https://bugs.webkit.org/show_bug.cgi?id=27627

Attachment 33385: Patch, changelogs
https://bugs.webkit.org/attachment.cgi?id=33385&action=review

------- Additional Comments from mitz at webkit.org
Minor style issues:

> -void AnimationBase::pauseAtTime(double t)
> +void AnimationBase::freezeAtTime(double t)

While you’re at it, please rename 't' to 'time'.

> +    ASSERT(m_startTime);	   // if m_startTime is zero, we haven't
started yet, so we'll get a bad pause time.

Since it ends with a period, it must begin with a capital “If” instead of “if”.


> +    void freezeAtTime(double t);

No need to name the parameter here.

> +    virtual void suspendAnimations(double time = 0);    // zero value for
time means "use currentTime()".

“Zero” instead of “zero”.


More information about the webkit-reviews mailing list