[webkit-reviews] review granted: [Bug 27398] Handle opacity and opacity animations on transform layers in Leopard : [Attachment 33113] Fixes a typo in the previous patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Mon Jul 20 15:33:47 PDT 2009


Simon Fraser (smfr) <simon.fraser at apple.com> has granted Chris Marrin
<cmarrin at apple.com>'s request for review:
Bug 27398: Handle opacity and opacity animations on transform layers in Leopard
https://bugs.webkit.org/show_bug.cgi?id=27398

Attachment 33113: Fixes a typo in the previous patch
https://bugs.webkit.org/attachment.cgi?id=33113&action=review

------- Additional Comments from Simon Fraser (smfr) <simon.fraser at apple.com>
> Index: WebCore/ChangeLog
> ===================================================================

> +	   * platform/graphics/GraphicsLayer.h:
> +	   (WebCore::GraphicsLayer::distributeOpacity):
> +	   (WebCore::GraphicsLayer::accumulatedOpacity):
> +	   * platform/graphics/mac/GraphicsLayerCA.h:
> +	   * platform/graphics/mac/GraphicsLayerCA.mm:
> +	   (WebCore::GraphicsLayerCA::setPreserves3D):
> +	   (WebCore::GraphicsLayerCA::setOpacity):
> +	   (WebCore::GraphicsLayerCA::animateFloat):
> +	   (WebCore::GraphicsLayerCA::swapFromOrToTiledLayer):
> +	   (WebCore::GraphicsLayerCA::accumulatedOpacity):
> +	   (WebCore::GraphicsLayerCA::distributeOpacity):
> +	   (WebCore::GraphicsLayerCA::setOpacityOnLayer):

This changelist seems stale.

> Index: WebCore/platform/graphics/GraphicsLayer.h
> ===================================================================

>  protected:
> +    virtual void distributeOpacityHelper(float) { }

Please rename this to internalSetOpacity(), or even setOpacityOnLayer(); the
name should say what it does.

> Index: WebCore/platform/graphics/mac/GraphicsLayerCA.mm
> ===================================================================

> +void GraphicsLayerCA::distributeOpacityHelper(float accumulatedOpacity)
> +{
> +    [ (preserves3D() ? m_layer.get() : primaryLayer())
setOpacity:accumulatedOpacity];
> +}

You've got an extra space after the first [

r=me with those adjustments.


More information about the webkit-reviews mailing list