[webkit-reviews] review granted: [Bug 23207] Move currentTime() from WebCore into WTF (to use in WTF::MessageQueue::WaitForMessageTimed) : [Attachment 26560] Proposed patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Sat Jan 10 14:34:23 PST 2009


Darin Adler <darin at apple.com> has granted Dmitry Titov <dimich at chromium.org>'s
request for review:
Bug 23207: Move currentTime() from WebCore into WTF (to use in
WTF::MessageQueue::WaitForMessageTimed)
https://bugs.webkit.org/show_bug.cgi?id=23207

Attachment 26560: Proposed patch
https://bugs.webkit.org/attachment.cgi?id=26560&action=review

------- Additional Comments from Darin Adler <darin at apple.com>
> +// Platform note: GTK should use gettimeofday everywhere except WIN, where 

Sentence fragment here. Also, I think it might be better to put this comment
after the includes rather than in the middle of them.

> +#if PLATFORM(MAC)
> +double currentTime()
> +{
> +    return CFAbsoluteTimeGetCurrent() + kCFAbsoluteTimeIntervalSince1970;
> +}
> +#elif PLATFORM(WIN)

I think some blank lines here would make it easier to read. The per-platform
sections are large enough that a little more vertical whitespace will make it
easier to spot the boundaries.

r=me


More information about the webkit-reviews mailing list