[webkit-reviews] review granted: [Bug 23210] Make it easier for ports to define custom UI for media controls : [Attachment 26566] proposed patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Fri Jan 9 13:13:05 PST 2009


Eric Seidel <eric at webkit.org> has granted Eric Carlson
<eric.carlson at apple.com>'s request for review:
Bug 23210: Make it easier for ports to define custom UI for media controls
https://bugs.webkit.org/show_bug.cgi?id=23210

Attachment 26566: proposed patch
https://bugs.webkit.org/attachment.cgi?id=26566&action=review

------- Additional Comments from Eric Seidel <eric at webkit.org>
I would expect this to be either:
const String& or String.  I'm not sure what const String would do for you.

The preferred webkit style is no else after return:
+    if (renderer() && renderer()->style()->hasAppearance())
+	 return theme()->hitTestMediaControlPart(renderer(), absPoint);
+    else
+	 return false;

No need for "o" here:
+    virtual bool hitTestMediaControlPart(RenderObject* o, const IntPoint&
absPoint);

Otherwise it looks fine.  If you're a commiter, go ahead and fix the nits and
land, no need to see another patch.


More information about the webkit-reviews mailing list