[webkit-reviews] review granted: [Bug 23165] Add support for application cache dynamic entries : [Attachment 26496] Part1 - implement DOMStringList

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Jan 7 16:16:59 PST 2009

Darin Adler <darin at apple.com> has granted Alexey Proskuryakov <ap at webkit.org>'s
request for review:
Bug 23165: Add support for application cache dynamic entries

Attachment 26496: Part1 - implement DOMStringList

------- Additional Comments from Darin Adler <darin at apple.com>
> +	   static PassRefPtr<StaticStringList> create(const Vector<String>&
> +	   {
> +	       return adoptRef(new StaticStringList(strings));
> +	   }

It'd be more efficient to make this adopt a vector rather than copying a
vector. You'd then probably call it adopt rather than create. And you could
implement it by doing a swap and then a clear. Although that's not the perfect
name, I think it's pretty good.

> Index: WebCore/loader/appcache/ApplicationCacheGroup.cpp
> ===================================================================
> --- WebCore/loader/appcache/ApplicationCacheGroup.cpp (revision 39671)
> +++ WebCore/loader/appcache/ApplicationCacheGroup.cpp (working copy)

Should revert the change to this file.


More information about the webkit-reviews mailing list