[webkit-reviews] review granted: [Bug 23090] Redraw issue with width and opacity change : [Attachment 26400] Improved patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Sat Jan 3 20:44:11 PST 2009

Darin Adler <darin at apple.com> has granted Simon Fraser (smfr)
<simon.fraser at apple.com>'s request for review:
Bug 23090: Redraw issue with width and opacity change

Attachment 26400: Improved patch

------- Additional Comments from Darin Adler <darin at apple.com>
> +    bool hasOpacity() const { return rareNonInheritedData->opacity < 1; }

I'm not a huge fan of this name for the function. What this function means is
that you have non-standard opacity, non-opaque opacity. It says nothing about
whether you have any CSS opacity rules, for example. You could have one saying
opacity: 1.

But the real problem is it doesn't make sense to say that a fully opaque object
with an opacity of "1" does not have opacity.

I'd suggest just saying opacity() < 1 at the call site, or coming up with a
better name for this helper function.

r=me with or without a change to that

More information about the webkit-reviews mailing list