[webkit-reviews] review granted: [Bug 23025] Simplifying DOMTimer lifetime management code : [Attachment 26300] Proposed patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Fri Jan 2 10:58:55 PST 2009

Darin Adler <darin at apple.com> has granted Dmitry Titov <dimich at chromium.org>'s
request for review:
Bug 23025: Simplifying DOMTimer lifetime management code

Attachment 26300: Proposed patch

------- Additional Comments from Darin Adler <darin at apple.com>
> -    static_cast<Document*>(context)->removeTimeout(timeoutId);
> +    DOMTimer* timer =
> +    delete timer;

I personally would like this to just be a one liner without a local variable.

> -    ActiveDOMObject::contextDestroyed();
> +    ActiveDOMObject::contextDestroyed();  // Clears

Is adding this comment really an improvement?

Normally we use one space before the "//".


More information about the webkit-reviews mailing list