[webkit-reviews] review granted: [Bug 23923] HTMLMediaElement should implement mediaPlayerVolumeChanged : [Attachment 27604] proposed patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Thu Feb 12 14:16:03 PST 2009


Simon Fraser (smfr) <simon.fraser at apple.com> has granted Eric Carlson
<eric.carlson at apple.com>'s request for review:
Bug 23923: HTMLMediaElement should implement mediaPlayerVolumeChanged
https://bugs.webkit.org/show_bug.cgi?id=23923

Attachment 27604: proposed patch
https://bugs.webkit.org/attachment.cgi?id=27604&action=review

------- Additional Comments from Simon Fraser (smfr) <simon.fraser at apple.com>
> Index: WebCore/html/HTMLMediaElement.cpp
> ===================================================================

> +    // avoid recursion when the player reports volume changes

Sentence case.

> Index: WebCore/html/HTMLMediaElement.h
> ===================================================================

> +    bool processingMediaPlayerCallback() { return
m_processingMediaPlayerCallback > 0; };

Make this |const|

> +    void setProcessingMediaPlayerCallback(bool processing) {
m_processingMediaPlayerCallback += (processing ? 1 : -1); }

To avoid the somewhat hard to read 'true', 'false' args, maybe have 2 methods
(begin/end).
Add an assertion to check that m_processingMediaPlayerCallback never goes
negative, and make it signed.


More information about the webkit-reviews mailing list