[webkit-reviews] review granted: [Bug 23931] Move some paint functions out of RenderObject : [Attachment 27612] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Thu Feb 12 11:25:31 PST 2009


Simon Fraser (smfr) <simon.fraser at apple.com> has granted Dave Hyatt
<hyatt at apple.com>'s request for review:
Bug 23931: Move some paint functions out of RenderObject
https://bugs.webkit.org/show_bug.cgi?id=23931

Attachment 27612: Patch
https://bugs.webkit.org/attachment.cgi?id=27612&action=review

------- Additional Comments from Simon Fraser (smfr) <simon.fraser at apple.com>
> +void RenderObject::drawLineForBoxSide(GraphicsContext* graphicsContext, int
x1, int y1, int x2, int y2,
> +					 BoxSide s, Color c, const Color&
textcolor, EBorderStyle style,
> +					 int adjbw1, int adjbw2)

Would be great to rename those parameters.

> Index: rendering/RenderObject.h
> ===================================================================
> --- rendering/RenderObject.h	(revision 40881)
> +++ rendering/RenderObject.h	(working copy)
> @@ -88,6 +88,15 @@ enum HitTestAction {
>      HitTestForeground
>  };
>  
> +// Sides used when drawing borders and outlines.  This is in RenderObject
rather than RenderBoxModelObject since outlines can
> +// be drawn by SVG around bounding boxes.
> +enum BoxSide {
> +    BSTop,
> +    BSBottom,
> +    BSLeft,
> +    BSRight
> +};

I don't think abbreviating BoxSide to BS is worth it. Would prefer to see
BoxSideTop etc.

r=me with or without the renames.


More information about the webkit-reviews mailing list