[webkit-reviews] review granted: [Bug 23868] Add HTMLInputElement, HTMLOptionsCollection V8 custom bindings : [Attachment 27520] Add HTMLInputElement and HTMLOptionsCollection V8 custom bindings

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Tue Feb 10 13:35:51 PST 2009


Eric Seidel <eric at webkit.org> has granted Dimitri Glazkov (Google)
<dglazkov at chromium.org>'s request for review:
Bug 23868: Add HTMLInputElement, HTMLOptionsCollection V8 custom bindings
https://bugs.webkit.org/show_bug.cgi?id=23868

Attachment 27520: Add HTMLInputElement and HTMLOptionsCollection V8 custom
bindings
https://bugs.webkit.org/attachment.cgi?id=27520&action=review

------- Additional Comments from Eric Seidel <eric at webkit.org>
A couple style issues:

 62	if (!isnan(v) && !isinf(v)) {
 63	    if (v < 0.0) {
 64		ec = INDEX_SIZE_ERR;
 65	    } else if (v > static_cast<double>(UINT_MAX)) {
 66		newLength = UINT_MAX;
 67	    } else {
 68		newLength = static_cast<unsigned>(v);
 69	    }
 70	}
 71	if (!ec) imp->setLength(value->Uint32Value(), ec);

Otherwise looks great.

We need to find a better name for V8Proxy.


More information about the webkit-reviews mailing list