[webkit-reviews] review granted: [Bug 23741] StyleRareNonInheritedData::operator==() should not compare ContentData objects by pointer : [Attachment 27411] Patch v2

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Fri Feb 6 13:41:57 PST 2009


Darin Adler <darin at apple.com> has granted David Kilzer (ddkilzer)
<ddkilzer at webkit.org>'s request for review:
Bug 23741: StyleRareNonInheritedData::operator==() should not compare
ContentData objects by pointer
https://bugs.webkit.org/show_bug.cgi?id=23741

Attachment 27411: Patch v2
https://bugs.webkit.org/attachment.cgi?id=27411&action=review

------- Additional Comments from Darin Adler <darin at apple.com>
> -    bool contentDataEquivalent(const RenderStyle* otherStyle) const;
> +    bool contentDataEquivalent(const RenderStyle* otherStyle) const { return
const_cast<RenderStyle*>(this)->rareNonInheritedData->contentDataEquivalent(*(c
onst_cast<RenderStyle*>(otherStyle)->rareNonInheritedData)); }

I think this would be slightly more readable for me without the extra set of
parentheses after the "*".

r=me


More information about the webkit-reviews mailing list