[webkit-reviews] review granted: [Bug 23676] Speed up uses of reserveCapacity on new vectors by adding a new reserveInitialCapacity : [Attachment 27239] patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Sun Feb 1 20:17:39 PST 2009


Dave Hyatt <hyatt at apple.com> has granted Darin Adler <darin at apple.com>'s
request for review:
Bug 23676: Speed up uses of reserveCapacity on new vectors by adding a new
reserveInitialCapacity
https://bugs.webkit.org/show_bug.cgi?id=23676

Attachment 27239: patch
https://bugs.webkit.org/attachment.cgi?id=27239&action=review

------- Additional Comments from Dave Hyatt <hyatt at apple.com>
I see a couple of cases where inline capacity could have just been used instead
of wasting an extra call on reserveCapacity or reserveInitialCapacity.	For
example:

textBuffer.reserveInitialCapacity(cMaxSegmentSize);

Could you go through these changes and look for any that just used a fixed size
constant all the time and convert them to use inline capacity instead?	I think
that would make those cases more readable and help make the intent of
reserveInitialCapacity more clear.

r=me


More information about the webkit-reviews mailing list