[webkit-reviews] review granted: [Bug 31997] LayoutTests/transitions/change-values-during-transition.html is flaky : [Attachment 44042] Change check for 50% done to 500ms, not 600ms. Other assorted cleanups.
bugzilla-daemon at webkit.org
bugzilla-daemon at webkit.org
Tue Dec 1 10:23:10 PST 2009
Darin Adler <darin at apple.com> has granted Julie Parent <jparent at google.com>'s
request for review:
Bug 31997: LayoutTests/transitions/change-values-during-transition.html is
flaky
https://bugs.webkit.org/show_bug.cgi?id=31997
Attachment 44042: Change check for 50% done to 500ms, not 600ms. Other
assorted cleanups.
https://bugs.webkit.org/attachment.cgi?id=44042&action=review
------- Additional Comments from Darin Adler <darin at apple.com>
I wish there was a way to isolate timing-dependent tests separately from the
vast majority of tests that can run at any speed. I'd prefer to not have tests
that pass or fail based on the speed or load of the computer, but if we do
knowingly have them it would be *so* much better if they were identified
somehow.
My comments have little to do with this patch, but rather with the original
test.
I think it's unfortunate that our function to tell us if two values are close
enough is called "isEqual" -- I would call it "isCloseEnough".
> + function getXPosition() {
> + var t =
window.getComputedStyle(document.getElementById('box')).webkitTransform;
> + t = t.split("(");
> + t = t[1].split(",");
> + return t[4];
> + }
The brace style is to put the function opening brace on a separate line.
> + document.getElementById('result').innerHTML = result;
Should use innerText or textContent, since this is not HTML.
r=me
More information about the webkit-reviews
mailing list