[webkit-reviews] review granted: [Bug 28370] check-webkit-style: add check for 'using std::foo; ' statements : [Attachment 34940] Patch v1

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Sun Aug 16 16:31:22 PDT 2009

David Levin <levin at chromium.org> has granted David Kilzer (ddkilzer)
<ddkilzer at webkit.org>'s request for review:
Bug 28370: check-webkit-style: add check for 'using std::foo;' statements

Attachment 34940: Patch v1

------- Additional Comments from David Levin <levin at chromium.org>
> +	     'Use \'using namespace std;\' instead of \'using std::%s;\'.' %

Consider using "" for the outer quotes to avoid the \' because it makes it
easier to read. Like this:

	  "Use 'using namespace std;' instead of 'using std::%s;'." %

> diff --git a/WebKitTools/Scripts/modules/cpp_style_unittest.py
> +	       'Use \'using namespace std;\' instead of \'using std::min;\'.'

Consider using "" for the outer quotes to avoid the \'.

More information about the webkit-reviews mailing list