[webkit-reviews] review denied: [Bug 28280] WebInspector: Evaluating objects while on a breakpoint dumps string representation instead of live object. : [Attachment 34841] patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Fri Aug 14 08:46:29 PDT 2009


Timothy Hatcher <timothy at hatcher.name> has denied Pavel Feldman
<pfeldman at chromium.org>'s request for review:
Bug 28280: WebInspector: Evaluating objects while on a breakpoint dumps string
representation instead of live object.
https://bugs.webkit.org/show_bug.cgi?id=28280

Attachment 34841: patch
https://bugs.webkit.org/attachment.cgi?id=34841&action=review

------- Additional Comments from Timothy Hatcher <timothy at hatcher.name>

> +	       function(result, isException) {
> +		   if (!isException)
> +		       result = JSON.parse(result);
> +		   reportCompletions(result, isException);
> +	       });

Can you break this out into a named function so it is easier to read? It took
me a second to realize this was being passed as an argument.


More information about the webkit-reviews mailing list