[webkit-reviews] review denied: [Bug 25347] Add a FrameLoaderClient callback for the ResourceRetrievedByXMLHttpRequest. : [Attachment 29714] patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Apr 29 10:47:59 PDT 2009


Timothy Hatcher <timothy at hatcher.name> has denied Pavel Feldman
<pfeldman at chromium.org>'s request for review:
Bug 25347: Add a FrameLoaderClient callback for the
ResourceRetrievedByXMLHttpRequest.
https://bugs.webkit.org/show_bug.cgi?id=25347

Attachment 29714: patch
https://bugs.webkit.org/attachment.cgi?id=29714&action=review

------- Additional Comments from Timothy Hatcher <timothy at hatcher.name>
+	 virtual void dispatchResourceRetrievedByXMLHttpRequest(unsigned long,
const WebCore::ScriptString&);

The name for this function does not match other client functions.

Something like this would fit better:

dispatchDidLoadResourceByXMLHttpRequest

+	 void resourceRetrievedByXMLHttpRequest(unsigned long identifier, const
ScriptString& sourceString);

This should be renamed to something that matches too. Maybe:

didLoadResourceByXMLHttpRequest


More information about the webkit-reviews mailing list