[webkit-reviews] review granted: [Bug 25202] Improve performance of repeated callbacks into the VM : [Attachment 29490] Call caching

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Tue Apr 14 23:21:53 PDT 2009


Cameron Zwarich (cpst) <cwzwarich at uwaterloo.ca> has granted Oliver Hunt
<oliver at apple.com>'s request for review:
Bug 25202: Improve performance of repeated callbacks into the VM
https://bugs.webkit.org/show_bug.cgi?id=25202

Attachment 29490: Call caching
https://bugs.webkit.org/attachment.cgi?id=29490&action=review

------- Additional Comments from Cameron Zwarich (cpst)
<cwzwarich at uwaterloo.ca>
There is extra whitespace on line 186 of Interpreter.h.

You use i++ in a few places where ++i would better match our style.

The CallFrameClosure struct has all of its members public but all of them have
the m_ prefix in front of them. It seems to be the style elsewhere in JSC to
remove the prefix if the class is actually a pure struct. In this case there
are also two methods that operate on the members in nontrivial ways, but there
are unlikely to be more. I suggest removing the m_ prefices and leaving the
rest as-is. If this is unreasonable or bad, let me know.

> void setArgument(int n, JSValuePtr v)

I think that we could come up with better names for these parameters. I think v
could be 'value', something similar for 'n'.

Other than that, r=me.


More information about the webkit-reviews mailing list