[webkit-reviews] review denied: [Bug 20746] Port WebKit to Qt on Windows CE : [Attachment 23296] Change DateMath.cpp to not use errno with strtol

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Mon Sep 15 14:39:45 PDT 2008


Eric Seidel <eric at webkit.org> has denied Simon Hausmann <hausmann at webkit.org>'s
request for review:
Bug 20746: Port WebKit to Qt on Windows CE
https://bugs.webkit.org/show_bug.cgi?id=20746

Attachment 23296: Change DateMath.cpp to not use errno with strtol
https://bugs.webkit.org/attachment.cgi?id=23296&action=edit

------- Additional Comments from Eric Seidel <eric at webkit.org>
Seems cleaner would be to just have a wrapper function which handled using
errno or not and returned a bool.  We are generally against Macros in WebKit
code (as they make things harder to read and debug).

Here would be an example:

static bool parseLong(const char* string, char*& stopPosition, long maxLength)
{
#if HAVE(ERRNO)
   strtol(string, stopPosition, maxLength);
   return (errno = 0);
#else
  // wince path
#endif
}


More information about the webkit-reviews mailing list