[webkit-reviews] review granted: [Bug 21781] WebCore::Settings should have a maximum image size setting : [Attachment 24549] Patch v1

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Oct 22 12:17:47 PDT 2008


Antti Koivisto <koivisto at iki.fi> has granted David Kilzer (ddkilzer)
<ddkilzer at webkit.org>'s request for review:
Bug 21781: WebCore::Settings should have a maximum image size setting
https://bugs.webkit.org/show_bug.cgi?id=21781

Attachment 24549: Patch v1
https://bugs.webkit.org/attachment.cgi?id=24549&action=edit

------- Additional Comments from Antti Koivisto <koivisto at iki.fi>
r=me, with some comments.

+	 frame = docLoader() ? docLoader()->frame() : 0;

+    DocLoader* docLoader() const { return m_docLoader; }
+

The CachedResource::m_docLoader is non-zero only in some special cases (it
should have a better name). Using m_request->docLoader() covers all cases we
care about. These changes are probably not needed.

	     // FIXME: I'm not convinced this case can even be hit.

I guess this FIXME can go now. We clearly can hit this case when maxImageSize
is limited (plus it was not true even before). 

+	 void setMaximumImageSize(size_t size) { m_maximumImageSize = size; }
+	 size_t maximumImageSize() const { return m_maximumImageSize; }

How about maximumDecodedImageSize to avoid confusion between encoded and
decoded size?


More information about the webkit-reviews mailing list