[webkit-reviews] review granted: [Bug 21642] Abstract out active object tracking : [Attachment 24454] proposed patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Fri Oct 17 00:53:18 PDT 2008


Sam Weinig <sam at webkit.org> has granted Alexey Proskuryakov <ap at webkit.org>'s
request for review:
Bug 21642: Abstract out active object tracking
https://bugs.webkit.org/show_bug.cgi?id=21642

Attachment 24454: proposed patch
https://bugs.webkit.org/attachment.cgi?id=24454&action=edit

------- Additional Comments from Sam Weinig <sam at webkit.org>
+	 ActiveDOMObject(Document* document, void* upcastPointer);
The document parameter name here is not needed.

+	 template<class T> void setPendingActivity(T* This)
+	 {
+	     ASSERT(This == this);
We don't usually have variables that start with a capital letter.  Perhaps
thisObject?

+} // namespace WebCore
+
+#endif // MessagePort_h

You meant ActiveDOMObject_h I think.

My main concern with this patch is the name ActiveDOMObject, which I don't
think conveys the idea intended.  I also think it may be cleaner to store the
upcaster pointer in the ActiveDOMObject instead of the HashMap.  

r=me.


More information about the webkit-reviews mailing list