[webkit-reviews] review denied: [Bug 21412] Refactor user initiated profile count to be more stable : [Attachment 24126] Proposed patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Mon Oct 6 15:06:14 PDT 2008


Timothy Hatcher <timothy at hatcher.name> has denied Kevin McCullough
<kmccullough at apple.com>'s request for review:
Bug 21412: Refactor user initiated profile count to be more stable
https://bugs.webkit.org/show_bug.cgi?id=21412

Attachment 24126: Proposed patch
https://bugs.webkit.org/attachment.cgi?id=24126&action=edit

------- Additional Comments from Timothy Hatcher <timothy at hatcher.name>
I am not sure m_startedProfileNumber is a good name. Maybe
m_runningUserInitiatedProfileNumber, m_recordingUserInitiatedProfileNumber or
m_activeUserInitiatedProfileNumber?

 137	     if (profile.title.indexOf(UserInitiatedProfileName) != 0) {

Use !== here.

 237	     if (title.indexOf(UserInitiatedProfileName, 0) == 0) {

Use === here.

 238		 title = WebInspector.UIString("Profile %d",
title.substring(35));

Use UserInitiatedProfileName.length instead of the magic number.

 380	 if (this.profile.title.indexOf(UserInitiatedProfileName, 0) == 0)
 381	     this._profileNumber = this.profile.title.substring(35);

Same applies here: === and no magic number. Also indexOf only takes 1 argument.


 398	     if (this.profile.title.indexOf(UserInitiatedProfileName, 0) == 0)

The indexOf function only takes 1 argument and use ===.

443  console.log("followLink");

r=me to remove that console.log in a separate commit.

r- for now.


More information about the webkit-reviews mailing list