[webkit-reviews] review granted: [Bug 21810] Remove use of static C++ objects that are destroyed at exit time (destructors) : [Attachment 25143] JavaScriptCore only patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Thu Nov 13 16:59:09 PST 2008


Darin Adler <darin at apple.com> has granted Greg Bolsinga <bolsinga at apple.com>'s
request for review:
Bug 21810: Remove use of static C++ objects that are destroyed at exit time
(destructors)
https://bugs.webkit.org/show_bug.cgi?id=21810

Attachment 25143: JavaScriptCore only patch
https://bugs.webkit.org/attachment.cgi?id=25143&action=review

------- Additional Comments from Darin Adler <darin at apple.com>
> +#define DEFINE_STATIC_LOCAL_ASSIGN(type, name, data) \
> +    static type* name##Ptr = data; \
> +    type& name = *name##Ptr

I think we should come up with a better name for this later. I'm not sure this
is really a static local at all and if it is, I think the word "pointer" needs
to be in the name somewhere, since data is a type*, not an initialization
parameter for a type. Maybe DEFINE_STATIC_LOCAL_WITH_POINTER. Now I almost wish
I hadn't asked for the Cursor class changes!

>  #include "config.h"
> +#include "StdLibExtras.h"
>  #include "Threading.h"

Threading.h here is the file's "own" header, so "StdLibExtras.h" should go in a
separate include paragraph below.

r=me


More information about the webkit-reviews mailing list