[webkit-reviews] review granted: [Bug 17133] Should support pausing JavaScript execution without hanging the process : [Attachment 19771] [WIP] Pause JS timers, block javascript: URIs, block JS event handlers

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Fri Mar 14 13:12:44 PDT 2008


Geoffrey Garen <ggaren at apple.com> has granted 's request for review:
Bug 17133: Should support pausing JavaScript execution without hanging the
process
http://bugs.webkit.org/show_bug.cgi?id=17133

Attachment 19771: [WIP] Pause JS timers, block javascript: URIs, block JS event
handlers
http://bugs.webkit.org/attachment.cgi?id=19771&action=edit

------- Additional Comments from Geoffrey Garen <ggaren at apple.com>
I think setPaused / isPaused would be a better naming scheme than
setJavaScriptExecutionAllowed  / javaScriptExecutionAllowed. It matches the
style of setEnabled / isEnabled, it's more terse, and it's more specific about
why JavaScript execution is not allowed, and what will happen to attempts to
execute JavaScript.

+void KJSProxy::setJavaScriptExecutionAllowed(bool allowed)
+{
+    if (!m_globalObject)
+	 return;
+

This code seems wrong. It means that a proxy that didn't have a global object
wouldn't "get the memo" about JavaScript being paused, so it might start up JS
execution at a later time.

r=me, with comments


More information about the webkit-reviews mailing list