[webkit-reviews] review granted: [Bug 16764] DOMRange doesn't correctly re-size when inserting items (Acid3) : [Attachment 18299] Proposed patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Sun Jan 6 11:23:31 PST 2008

Darin Adler <darin at apple.com> has granted Andrew Wellington
<proton at wiretapped.net>'s request for review:
Bug 16764: DOMRange doesn't correctly re-size when inserting items (Acid3)

Attachment 18299: Proposed patch

------- Additional Comments from Darin Adler <darin at apple.com>
Usually a count would be named with a noun. The word "move" is more like a
verb, so "offsetMove" is not a great variable name. Maybe offsetDelta or

+    if (m_startContainer == m_endContainer)
+	 m_endOffset += offsetMove;

There's no if statement needed here -- you already ensured that the variable
will be 0 in the case where the two are not equal.


More information about the webkit-reviews mailing list