[webkit-reviews] review denied: [Bug 22352] Annotating opcodes with length : [Attachment 25261] Proposed patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Mon Dec 8 12:47:17 PST 2008


Cameron Zwarich (cpst) <cwzwarich at uwaterloo.ca> has denied Judit Jász
<jasy at inf.u-szeged.hu>'s request for review:
Bug 22352: Annotating opcodes with length
https://bugs.webkit.org/show_bug.cgi?id=22352

Attachment 25261: Proposed patch
https://bugs.webkit.org/attachment.cgi?id=25261&action=review

------- Additional Comments from Cameron Zwarich (cpst)
<cwzwarich at uwaterloo.ca>
This is a really great idea. I only see two issues. First, you use an enum to
store the lengths. It would make a lot more sense to use const ints instead. It
would also make more sense to use OPCODE_SIZE instead of GET_OPCODE_SIZE, since
there is no lookup and the value is resolved at compile time. I am r-'ing this,
but I really like the change and it is something we definitely need.

If you don't want to update this patch to ToT WebKit due to all the conflicts,
you can tell me that you want me to do it. Or you can just do the bytecode
interpreter and I can do the JIT, since the JIT code is changing a lot every
day now.


More information about the webkit-reviews mailing list