[webkit-reviews] review denied: [Bug 22528] Move currentThreadStackBase() to WTF : [Attachment 25554] Share utility code for GC implementations

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Fri Dec 5 10:06:04 PST 2008

Darin Adler <darin at apple.com> has denied Alp Toker <alp at nuanti.com>'s request
for review:
Bug 22528: Move currentThreadStackBase() to WTF

Attachment 25554: Share utility code for GC implementations

------- Additional Comments from Darin Adler <darin at apple.com>
I don't like the word "utilities" in a file name; it seems to be a word without
meaning. I suggest calling this something like MachineStack.h.

If the macro is going to be in a header file, then I think it should be changed
into an inline function that takes a const void*, so we don't have to add a
WTF_ prefix to it.

Why include <stdlib.h>? I think all you need in this header is the type
intptr_t, and that's not in <stdlib.h>.

More information about the webkit-reviews mailing list