[webkit-reviews] review granted: [Bug 20343] [CAIRO] half functionality of border-radius : [Attachment 22724] Fixes border-radius

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Fri Aug 22 02:27:49 PDT 2008

Eric Seidel <eric at webkit.org> has granted Dirk Schulze <vbs85 at gmx.de>'s request
for review:
Bug 20343: [CAIRO] half functionality of border-radius

Attachment 22724: Fixes border-radius

------- Additional Comments from Eric Seidel <eric at webkit.org>
I'm not sure I 100% understand the code, but it looks sane enough.

falen really could have a better variable name.  "fa" too.

It seems sad there is not a slicker way to handle this:
+    if (w != h)
+	 cairo_scale(cr, 1., scaleFactor);
+    cairo_arc_negative(cr, x + hRadius, (y + vRadius) * reverseScaleFactor,
hRadius, -fa * M_PI/180, -falen * M_PI/180);
+    if (w != h)
+	 cairo_scale(cr, 1., reverseScaleFactor);

w/o setting and un-setting the scale factor.

More information about the webkit-reviews mailing list