[webkit-reviews] review denied: [Bug 19155] Inspector should support console.dir : [Attachment 22788] proposed patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Thu Aug 14 15:45:40 PDT 2008

Timothy Hatcher <timothy at hatcher.name> has denied Keishi Hattori
<casey.hattori at gmail.com>'s request for review:
Bug 19155: Inspector should support console.dir

Attachment 22788: proposed patch

------- Additional Comments from Timothy Hatcher <timothy at hatcher.name>
This is exciting!

I am r-ing this because it should reuse other code we have to show object
properties. WebInspector.ObjectPropertiesSection

You should give DirMessageLevel a sensible name, maybe ObjectMessageLevel.

The more I think about the message levels the more we are abusing them. We
almost need a type identifier for console messages. And this would use a custom
type with the log level. Group should have a type too, and be log level. Make

ConsoleDomInspector is not a great name. And I don't think we need another
object for that, we can just make console message know how to show this message

More information about the webkit-reviews mailing list