[webkit-reviews] review denied: [Bug 18468] Cairo build does not
work with CURL : [Attachment 20512] Cairo Curl build fix
bugzilla-daemon at webkit.org
bugzilla-daemon at webkit.org
Mon Apr 14 08:02:47 PDT 2008
Adam Roben (aroben) <aroben at apple.com> has denied Daniel Zucker
<zucker at wake3.com>'s request for review:
Bug 18468: Cairo build does not work with CURL
http://bugs.webkit.org/show_bug.cgi?id=18468
Attachment 20512: Cairo Curl build fix
http://bugs.webkit.org/attachment.cgi?id=20512&action=edit
------- Additional Comments from Adam Roben (aroben) <aroben at apple.com>
+#if PLATFORM(CF)
+#include <CoreFoundation/CoreFoundation.h>
+#include <WebKitSystemInterface/WebKitSystemInterface.h>
+#endif
Can you explain why these changes are needed? In particular I don't see a
reason to ever include WebKitSystemInterface.h in another header file, since
WebKitSystemInterface.h only declares functions, not types. Can we move these
#includes to the source files that require them? If they're needed by this
header, can we replace them with the appropriate forward declarations?
+++ WebCore/platform/network/curl/ResourceHandleCurl.cpp (working copy)
@@ -176,4 +176,11 @@ void ResourceHandle::loadResourceSynchro
response = syncLoader.resourceResponse();
}
+//stubs needed for windows version
+void ResourceHandle::didReceiveAuthenticationChallenge(const
AuthenticationChallenge&) {notImplemented();};
+void ResourceHandle::receivedCredential(const AuthenticationChallenge&, const
Credential&) {notImplemented();};
+void ResourceHandle::receivedRequestToContinueWithoutCredential(const
AuthenticationChallenge&) {notImplemented();};
+void ResourceHandle::receivedCancellation(const
AuthenticationChallenge&){notImplemented();};
+
+
Even though these are just stubs I think you should format them correctly. That
way it'll be easier to see the changes when someone does implement them.
+++ WebKit/win/WebError.h (working copy)
@@ -28,6 +28,8 @@
#include "WebKit.h"
+#include <wtf/RetainPtr.h>
+
This #include should follow the WebCore #includes, to keep things in
lexicographical order.
More information about the webkit-reviews
mailing list