[webkit-reviews] review requested: [Bug 15334] Split ResourceResponse into platform specific files : [Attachment 16707] Patch updated with Darin's comment

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Oct 17 14:17:00 PDT 2007


Julien Chaffraix <julien.chaffraix at gmail.com> has asked  for review:
Bug 15334: Split ResourceResponse into platform specific files
http://bugs.webkit.org/show_bug.cgi?id=15334

Attachment 16707: Patch updated with Darin's comment
http://bugs.webkit.org/attachment.cgi?id=16707&action=edit

------- Additional Comments from Julien Chaffraix <julien.chaffraix at gmail.com>
The new patch has been generated with "svn move" and "svn-create-patch". Thanks
for the tip.

Again the patch has been tested only on linux.

>+
>const_cast<ResourceResponse&>(asResourceResponse()).doUpdateResourceResponse()
;

> Why use const_cast here? Could we instead make the relevant members all be
> mutable?

After a quick look at the code, adding mutable to the members of 
ResourceResponseBase would leave only one member non-mutable so I do not think
that is worth it.

I agree that the 2 casts are not really beautiful. I have tried a lot of
alternatives and the conclusion is that we need the 2 casts.

> I'm always uncomfortable with the "do" prefix in cases like this.
> Perhaps we could come up with a more descriptive name for the function that
> does the actual work.

I could not find a better name. Maybe someone has a better idea.


More information about the webkit-reviews mailing list