[webkit-reviews] review requested: [Bug 15299] GTK: ChromeClientGtk.cpp does not implement mouseDidMoveOverElement() : [Attachment 16572] Fix signal not emitted when hovering on links in succession - update2

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Sun Oct 7 00:55:28 PDT 2007


Jan Alonzo <jmalonzo at gmail.com> has asked  for review:
Bug 15299: GTK: ChromeClientGtk.cpp does not implement
mouseDidMoveOverElement()
http://bugs.webkit.org/show_bug.cgi?id=15299

Attachment 16572: Fix signal not emitted when hovering on links in succession -
update2
http://bugs.webkit.org/attachment.cgi?id=16572&action=edit

------- Additional Comments from Jan Alonzo <jmalonzo at gmail.com>
(In reply to comment #22)
> m_hoveredLink.isEmpty())) {
> 
> The m_hoveredLink.isEmpty() part of this check is superfluous. If
> m_hoveredLink.isEmpty() will return true, then so will url != m_hoveredLink
> (since we already checked !url.isEmpty()).

Hi! Yeah you're right. Fixed in the updated patch.

> +	   m_hoveredLink = "";
> 
> It would be better to say:
> 
> m_hoveredLink = KURL();

Fixed.
 
> I think it would be good to rename m_hoveredLink to m_hoveredLinkURL.

Fixed.

> r- so we can get that redundant check in the if statement out of here.

Done. Thank you.



More information about the webkit-reviews mailing list