[webkit-reviews] review denied: [Bug 15299] GTK: ChromeClientGtk.cpp does not implement mouseDidMoveOverElement() : [Attachment 16569] Fix signal not emitted when hovering on links in succession - update

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Sat Oct 6 23:26:24 PDT 2007


Adam Roben <aroben at apple.com> has denied Jan Alonzo <jmalonzo at gmail.com>'s
request for review:
Bug 15299: GTK: ChromeClientGtk.cpp does not implement
mouseDidMoveOverElement()
http://bugs.webkit.org/show_bug.cgi?id=15299

Attachment 16569: Fix signal not emitted when hovering on links in succession -
update
http://bugs.webkit.org/attachment.cgi?id=16569&action=edit

------- Additional Comments from Adam Roben <aroben at apple.com>
+	 if (!url.isEmpty() && (url != m_hoveredLink ||
m_hoveredLink.isEmpty())) {

The m_hoveredLink.isEmpty() part of this check is superfluous. If
m_hoveredLink.isEmpty() will return true, then so will url != m_hoveredLink
(since we already checked !url.isEmpty()).

+	 m_hoveredLink = "";

It would be better to say:

m_hoveredLink = KURL();

I think it would be good to rename m_hoveredLink to m_hoveredLinkURL.

r- so we can get that redundant check in the if statement out of here.



More information about the webkit-reviews mailing list