[webkit-reviews] review requested: [Bug 16138] Reduce code duplication in WebView.cpp : [Attachment 17525] Refactor WebView's repaint rect code

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Sun Nov 25 22:50:45 PST 2007


Adam Roben <aroben at apple.com> has asked  for review:
Bug 16138: Reduce code duplication in WebView.cpp
http://bugs.webkit.org/show_bug.cgi?id=16138

Attachment 17525:	  Refactor WebView's repaint rect code
http://bugs.webkit.org/attachment.cgi?id=17525&action=edit

------- Additional Comments from Adam Roben <aroben at apple.com>

	Reviewed by NOBODY (OOPS!).

	* WebView.cpp:
	(getUpdateRects): Factored code out of updateBackingStore and paint
	into this new helper function.
	(WebView::updateBackingStore): Use getUpdateRects.
	(WebView::paint): Ditto.
	(WebView::paintIntoBackingStore): Changed to take a const IntRect&.
	(WebView::paintIntoWindow): Ditto.
	* WebView.h:
---
 WebKit/win/ChangeLog	|   15 +++++
 WebKit/win/WebView.cpp |  143 ++++++++++++++++++++++++------------------------
 WebKit/win/WebView.h	|    4 +-
 3 files changed, 88 insertions(+), 74 deletions(-)


More information about the webkit-reviews mailing list